Changeset 3223 in CLRX


Ignore:
Timestamp:
Jun 29, 2017, 10:40:05 AM (22 months ago)
Author:
matszpk
Message:

CLRadeonExtender: Add info about using old C++11 ABI in Linux binaries.

Location:
CLRadeonExtender/trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • CLRadeonExtender/trunk/README

    r3140 r3223  
    3434
    3535Read the INSTALL file.
     36
     376. Usage of libraries in binaries
     38
     39The default binary libraries for Linux are compiled for C++11 old ABI, hence you must add
     40option -D_GLIBCXX_USE_CXX11_ABI=0 to compiler commands if you are using GCC 5.0
     41or higher or compiler that by default uses new C++11 ABI.
     42
     43
     44
     45
  • CLRadeonExtender/trunk/README.md

    r3141 r3223  
    100100```
    101101
     102### Usage of libraries in binaries
     103
     104The default binary libraries for Linux are compiled for C++11 old ABI, hence you must add
     105option -D_GLIBCXX_USE_CXX11_ABI=0 to compiler commands if you are using GCC 5.0
     106or higher or compiler that by default uses new C++11 ABI.
    102107
    103108### Usage
Note: See TracChangeset for help on using the changeset viewer.